Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 18:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 20, 2025 - 15:24 EDT
Scheduled
Centrilogic Scheduled Maintenance Notification.
Maintenance Window: March 25th, 2025
Start Time: 06:00 PM EST
End Time: 10:00 PM EST
Service Call in Reference Number: 1107694
Service Location(s): Rochester Datacenter (ROC)
Services Affected: DR replication
Expected Impact: Multiple hits to replication traffic
Details: Centrilogic is performing maintenance in its Zerto DR replication environment to provide improved support and services.
If your contact information is incorrect, has recently changed, or you feel you have received this notification in error, please kindly provide us with your new details so we can ensure you do not miss any future communications.
Centrilogic’s support team will be available for assistance 24/7. For questions, concerns, or to report a problem about this notification, please contact our Operations Center: