We continue working with our facilities partner following a UPS hardware failure that impacted a redundant power path at the RSP Data Centre.
The affected power path has been restored, all services remain fully operational, and no customer impact has been identified. Replacement hardware has been expedited, with remediation tentatively scheduled for 8:00 PM EDT on September 25, 2026, pending final confirmation of parts delivery.
Operations and facilities teams are actively monitoring the environment as we work to restore full power redundancy. We will provide our next update by 12:00 PM EDT on September 25, 2026, or sooner if there are any significant developments.
Regards, Centrilogic Support Team
Posted Sep 24, 2026 - 17:59 EDT
Update
Dear Valued Clients,
We continue to work closely with our facilities contractor following a UPS hardware failure that impacted a redundant power path within our RSP Data Centre.
The affected power path remains restored, and all services continue to operate normally. Replacement hardware has been confirmed and expedited by our vendor. We are currently coordinating the repair schedule and expect to finalize the installation window shortly.
At this time, the environment remains stable, with no customer impact identified. Operations and facilities teams continue to closely monitor the site while remediation activities are completed.
Our next update will be provided by 18:00 ET.
Regards, Centrilogic Support Team
Posted Sep 24, 2026 - 14:23 EDT
Identified
Dear Valued Clients,
Thank you for your patience.
We continue to work closely with our facilities contractor following a UPS rectifier hardware failure that impacted a redundant power path within our RSP Data Centre.
The affected power path has been restored, and all services continue to operate normally. The root cause has been identified, and replacement hardware has been sourced and is in the process of being delivered. Our vendor is expediting shipment and installation activities.
At this time, the environment remains stable, with no customer impact identified. Operations and facilities teams continue to closely monitor the site while remediation is completed. Next update at 2pm EST.
Regards, Centrilogic Support Team.
Posted Sep 24, 2026 - 10:04 EDT
Update
Dear Valued Clients,
Thank you for your patience.
We continue to work with our facilities contractor following an infrastructure event affecting a redundant power path within a limited portion of the RSP Data Centre.
The impacted power path has been restored, and affected services have been restored. We have identified the root cause of the degraded redundancy and are working with our contractor on remediation to return the affected infrastructure to its normal operating state and restore full redundancy.
At this time, no broader impact to the RSP Data Centre environment has been identified. Our next update will be provided by 10:00 AM EDT on September 24, 2026, or sooner if significant new information becomes available.
Regards, Centrilogic Support Team.
Posted Sep 23, 2026 - 20:32 EDT
Update
Dear Valued Clients,
Thank you for your patience.
We continue to work with our facilities contractor following an infrastructure event affecting a redundant power path within a limited portion of the RSP Data Centre.
The impacted power path has been restored, and affected services have been restored. We have identified the root cause of the degraded redundancy and are working with our contractor on remediation to return the affected infrastructure to its normal operating state and restore full redundancy.
At this time, no broader impact to the RSP Data Centre environment has been identified. We will provide additional updates as information becomes available.
Regards, Centrilogic Support Team
Posted Sep 23, 2026 - 15:55 EDT
Update
Dear Valued Clients,
Thank you for your patience.
We continue to work with our facilities contractor to return the affected infrastructure to its normal operating state following an infrastructure event affecting a redundant power path within a limited portion of the RSP Data Centre.
The impacted power path has been restored. Our teams are validating affected systems and monitoring the environment while remediation efforts continue to restore full redundancy.
At this time, no broader impact to the RSP Data Centre environment has been identified. We will provide additional updates as new information becomes available.
Regards, Centrilogic Support Team
Posted Sep 23, 2026 - 08:51 EDT
Investigating
Dear Valued Clients,
We would like to inform you of an infrastructure event within the RSP Data Centre that has resulted in the loss of a redundant power path serving a limited portion of the facility.
At this time, all critical services remain operational, and there has been no impact to the broader RSP Data Centre environment. The affected systems continue to receive power through their primary path; however, the level of power redundancy has been temporarily reduced while remediation activities are completed.
Our facilities, infrastructure, and operations teams are actively engaged in assessing the condition and implementing corrective actions to restore full redundancy as quickly as possible. We are closely monitoring the environment and have taken appropriate measures to minimize operational risk during this period.
We will continue to provide updates as additional information becomes available or if conditions change. We appreciate your patience and understanding.