Users in North America may experience issues with join meeting functionality in Microsoft Teams.

Incident Report for Centrilogic

Resolved

Final Status:
Microsoft has identified a communication issue that occurred for a brief period between backend components that facilitate meeting join functionality, which resulted in impact. They will continue to closely monitor the service environment; however, their service telemetry indicates full remediation.

Start time: Wednesday, July 9, 2025 at 2:00 PM EDT
End time: Wednesday, July 9, 2025 at 2:12 PM EDT

User impact
Users in North America may have experienced issues with join meeting functionality in Microsoft Teams.

Preliminary root cause
A communication issue occurred for a brief period between backend components that facilitate meeting join functionality, which resulted in impact.
Posted Jul 09, 2025 - 16:05 EDT

Investigating

Microsoft Teams is currently experiencing an issue where users may be unable to join meetings. This issue has been acknowledged by Microsoft and is under investigation.

Recent update from Microsoft (Jul 9, 2025, 2:39 PM EDT):

"We’re investigating issues related to user reports of being unable to join Teams meetings. We’re currently reviewing system telemetry to identify the underlying cause."

Further updates will be shared as they become available.
Posted Jul 09, 2025 - 14:51 EDT