Major outage – Multiple customers impacted

Incident Report for Centrilogic

Resolved

Dear Valued Clients,
Our support team has identified the issue and network services are now available, we are actively monitoring the situation to ensure stability.
Thank you for your patience.
Posted Nov 04, 2025 - 16:16 EST

Update

We are continuing to investigate this issue.
Posted Nov 04, 2025 - 15:54 EST

Update

We are continuing to investigate this issue.
Posted Nov 04, 2025 - 15:45 EST

Update

We are continuing to investigate this issue.
Posted Nov 04, 2025 - 15:45 EST

Update

We are continuing to investigate this issue.
Posted Nov 04, 2025 - 15:42 EST

Investigating

Dear Valued Clients,
We regret to inform you that we are currently experiencing an unexpected outage at our Rochester Datacentre. Our technical teams are actively engaged and working diligently to identify and resolve the issue as quickly as possible. We understand the critical nature of your services and applications that rely on our infrastructure, and we sincerely apologize for any disruptions this may cause. Next update will be provided at 4.30pm
Posted Nov 04, 2025 - 15:38 EST
This incident affected: Network (Internet transit, Core routing/switching, backbone systems) (ROC Network) and Services (Dedicated and Shared hosting, Colocation, CPE) (USA-Services).