Utility power has been successfully restored at our data center facility located at 28 Mansfield Street, Rochester, New York. The facility has transitioned smoothly from generator power back to utility power as designed. All systems and services continue to operate normally, and no customer impact has been identified. Our teams will continue to monitor the environment to ensure ongoing stability. This incident is now considered resolved. Thank you for your patience.
Posted Mar 20, 2026 - 14:42 EDT
Identified
We are currently experiencing a utility power outage at our data center facility located at 28 Mansfield Street, Rochester, New York. The facility has smoothly transitioned to generator power as designed, and all systems and services continue to operate normally. At this time, no impact has been identified. Our teams are actively monitoring the situation while we await restoration from the utility provider. We will continue to provide updates should there be any change to service status.
Posted Mar 20, 2026 - 12:20 EDT
This incident affected: Environmental (Power/Cooling/Security) (ROC Environmental).