Microsoft has completed the rollback of the networking configuration change identified during the investigation. Based on Microsoft's monitoring and telemetry, service functionality has been restored for the vast majority of affected users.
Microsoft continues to review all known impact scenarios and is closely monitoring the environment to confirm full service restoration across all affected regions and tenants. At this time, service availability has significantly improved, and recovery efforts remain focused on validating resolution for any remaining affected users.
We will continue to monitor Microsoft's updates and provide additional information if further action is required.
Posted Jul 23, 2026 - 15:12 EDT
Monitoring
Microsoft has advised that service restoration efforts are progressing, with telemetry indicating improvement across affected services following traffic rerouting activities. Additional remediation actions remain underway as Microsoft continues to revert a recent networking configuration change and implement targeted traffic-routing adjustments to further reduce impact.
At this time, service functionality is being restored for affected users; however, some users may continue to experience intermittent access issues or degraded performance. Microsoft is actively monitoring recovery progress and validating improvements with impacted customers.
We will continue to monitor Microsoft's updates and provide further information as it becomes available
Posted Jul 23, 2026 - 14:27 EDT
Update
User impact: Users may be experiencing issues accessing or using Microsoft 365 services in the North America region.
Current status: Microsoft are continuing their investigation and are reviewing recent changes for potential correlation while they analyze service telemetry and available diagnostic data.
Scope of impact: Users accessing Microsoft 365 services through affected network paths in the North America region may be impacted.
Posted Jul 23, 2026 - 12:01 EDT
Investigating
Microsoft is currently investigating a SharePoint Online service issue affecting some users. Users may experience difficulties accessing SharePoint sites, slow performance, or navigation errors. At this time, Microsoft has not identified the root cause and is continuing its investigation. We are monitoring the situation closely and will provide further updates as Microsoft releases additional information.